开发者论坛

 找回密码
 注册 (请使用非IE浏览器)
查看: 4617|回复: 0

ASP.NET最新版开发.NET环境配置Visual Studo和SQL Server对应版本

[复制链接]

0

精华

8

贡献

1753

赞扬

特约版主

帖子
583
软币
4514
在线时间
274 小时
注册时间
2019-2-21
发表于 2020-11-30 09:33:03 | 显示全部楼层 |阅读模式

如下图所示,绿色Yes代表支持,红色No代表不支持。对于有些人觉得装了DevExpress后,VS工具箱没有,一般都是以下两大问题:
  • DevExpress的版本不支持你当前的VS版本,没有很正常。
  • 项目的.net版本并不支持当前版本DevExpress,修改项目的.net版本即可。
另外如果以上都没有问题的话,还有其他两种情况:
  • 请记住安装顺序,先装VS,后装DevExpress。
  • 以上都没问题的话,工具箱还是没有DevExpress控件的话,但是VS工具栏有DevExpress选项卡,则可以选择Repair Tool(重置工具箱:可以右击工具箱,或者选择DevExpress选项卡),如果VS工具栏上没有DevExpress选项卡的话,请到安装路径找到exe修复DevExpress。
ASP.NET MVC
框架
DevExpress ASP.NET MVC扩展支持以下ASP.NET MVC和.NET Framework版本。
ASP.NET MVC 框架

ASP.NET .NET框架

jQuery
DevExpress ASP.NET MVC扩展支持jQuery version 3.x。
注意:必须安装Microsoft .NET Framework 4和MVC 3才能运行DevExpress MVC演示,如果使用MVC 4,则需要稍作修改DevExpress MVC演示项目。
IDE
使用以下IDE开发具有DevExpress ASP.NET MVC扩展的MVC应用程序。


注意:从v18.2开始,DevExpress源代码面向C#6.0。 您仍可以在Visual Studio 2012和2013中使用我们的预编译程序集。但是,无法在这些Visual Studio版本中重新编译DevExpress源代码。
SQL Server
要在本地运行DevExpress ASP.NET MVC扩展演示,必须安装以下版本的Microsoft SQL当中的一个。
  • Microsoft SQL Server 2005 Express Edition (SP3)
  • Microsoft SQL Server 2008 Express Edition (SP1)
  • Microsoft SQL Server 2012 Express
  • Microsoft SQL Server 2012 Express LocalDB
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2016
需要Microsoft SQL Server,因为DevExpress演示使用本地部署的.mdf文件作为数据源。
如果使用的是Microsoft SQL Server Express的自定义命名实例,则需要浏览演示中的web.config文件中的connectionString参数条目,并将任何出现的默认实例名称(“ SQLEXPRESS”)替换为自定义实例 名称。
从v13.2开始,对于大多数流行的数据库引擎,DevExpress .NET演示中心会自动识别计算机上可用的数据库引擎。 从演示中心启动需要SQL Server的特定演示时,它将按以下顺序自动找到可用的DBMS实例:
  • .\SQLEXPRESS
  • (localdb)\vX
  • (local)
直接在Visual Studio中打开演示项目时,可以根据开发环境调整连接字符串。
Web Server
部署到IIS时,将默认应用程序池更改为.NET 4。

DevExpress技术交流群2:775869749      欢迎一起进群讨论

回复

使用道具 举报

Archiver|手机版|小黑屋|开发者网 ( 苏ICP备08004430号-2 )
版权所有:南京韵文教育信息咨询有限公司

GMT+8, 2022-5-24 16:44

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表